1-click instalace Nvidia/ATI ovladačů

Pomocí technologie 1-click je nyní možné instalovat binární ovladače pro grafické karty od Nvidie a ATI. Ovladače ATI/Nvidie nemohou být integrovány přímo do openSUSE díky licenci, ale díky 1-click technologii, by měla být jejich instalace pouhou rutinou.

1-click YMP(YaST MetaPackage) odkazy, které vytvořil Francis Giannaros, jsou dostupné i přes openSUSE wiki - Nvidia, ATI.

Autor: ra100

Komentáře

shinigami odpověděl -

Tohle je moc pekna novinka, jen to asi jeste bude chtit kapku dolestit, aby nebylo nutne jeste dodatecne menit xcong.org (mozna to neni obecny problem, u me to zatim bylo potreba vsude kde jsem instaloval).

Krom toho repository pro ATI obsahuje ovladace nepodporujici stare karty a ktery podle vseho prestane fungovat po prvnim update systemu ze site - obsahuje update jadra. Vysledek rozchazim doted:/ Uz aby byly ovladace distribuovatelne vedle jadra a v te spravne verzi...

Dosi odpověděl -

Vedle tlačítka pro instalaci nVidia legacy ovladačů by měl být alespoň odkaz na seznam podporovaných ovladačů a vysvětlení, že legacy ovladače jsou JENOM pro starší grafické karty a ty druhé JENOM pro novější.
Jinak se stane, že nezkušený (neznalý) uživatel prostě klikne na jeden z odkazů (na 50 % se netrefí) a pak se bude divit, že má po restartu jen textovou konzolu...
Načež prohlásí: "Zlatý Windows".

Libor odpověděl -

A co má uživatel v případě, kdy uvidí jenom textovou konzoli dělat ? Nějaký návod jak z toho ven ?

vladano odpověděl -

v konzoli se prihlasit jako root a bud naistalit spravny predem stazeny driver podle navodu na strankach Nvidie (nebo Ati) nebo napsat yast do konzole a spusti se podobne ovladaci prostredi Yastu (dosovskeho vzhledu), kde lze normalne pridat repozitare a nainstalovat spravny driver. Uz jsem to takto napravoval nekolikrat, kdyz se neco vysr..o.
To se mi na linuxu libi, ze kdyz uz jsem ten experimentator pokus omyl, tak to jde celkem snadno spravit :)

--
Let's talk about s.x - Suse linuX ;o)

Droll odpověděl -

Tak přesně tohle se mi stalo (až na ty "Zlatý Windows"), takže jdu opravovat :-)

-F- odpověděl -

A to by byl strasnej problem kdyby Linux nahlasil "Spatnej ovladac - vratil jsem posledni funkcni verzi" a nabehl x server? Takhle naskoci prikazova radka a porad si (a bez xserveru zapomen na internet aby sis precetl jak na to). Cokoliv u grafickyho OS prekousnu, ale kdyz nejede grafika :-( Chtelo by toto doresit. U 10.1 jsem nerozjel ovladace na grafarnu ani prt (max rozliseni 1024, ale jen 60Hz :-(( ) a to sem zkusil vsechny mozny navody a urcite to nebylo spatnym vyberem grafarny, tak snad 10.3 to bude OK.
PS: ti co si ctou tyhle stranky asi neprohlasujou "Zlaty Windows" :-)

lmich odpověděl -

Raz darmo, kliknutim mi to nainstalovalo balik ati-fglrxG01-kmp-default-8.41.7_2.6.22.5_30-1.1
aj s modulom /lib/modules/2.6.22.5-30-default/updates/fglrx.ko
Lenze ja mam po on-line update uz jadro 2.6.22.9-0.4.
Neviem ako chcu do buducna riesit to, ze polovica ludi bude mat updatnuty kernel a polovica distribucny kernel.

ra100 odpověděl -

"Lenze ja mam po on-line update uz jadro 2.6.22.9-0.4."
tam pomoze rekompilacia.obsiahly navod pre ATI

Neznámý odpověděl -

Jenze s takovou rekompilaci na zacatecnika ci prosteho uzivatele vubec nechodte ! :-(
Tato situace jenom dokazuje, jak je soucasny system, kdy jsou ovladace zavisle na kdejakem updatu jadra, _neudrzitelny_, pokud chceme Linux dostat k vetsimu poctu lidi. A o to snad OpenSUSE jde ne ?
Pri techto problemech - pokud nebudou reseny a stale se budou opakovat - bude rozsireni na desktopech stale pomerne male. Co udela zajemce o OpenSUSE po teto zkusenosti ? Samozrejme se vrati tam kde byl pred tim a o Linux uz nikdy ani nezavadi.

LiborA odpověděl -

Ano to je můj případ - jsem začátečník a volám o pomoc. Podle toho obsáhlého návodu jsem došel bez problémů až ke kroku 8. Tam mi však SAX nahlásil něco v tom smyslu, že nastavení nelze uložit či co (teď nejsme u toho počítače a budu až v pondělí) a po rebootu samozřejmě nenastartoval X server a musel jsem spustit SAX aby se nakonfiguroval - samozřejmě namísto Radeonu HD2400 (mám AGP verzi, takže možná je problém v tom) mám stále VESA ovladač :-(
Zkoušel jsem v kroku 8 i místo volání saxu použít příkaz aticonfig --initial , ale stejně jsem to nerozchodil. Zkusil jsem i starší verzi ovladačů, co kdyby ty fungovali, ale bohužel nic.
Takže jsem momentálně v situaci, kdy mám nachystaný rpm balíček s drivery pro platformu SUSE 10.2 AMD64 (používám SUSE 10. AMD-64) a to jak pro driver 8.40.4 i 8.41.7. Samozřejmě nainstalovaný je vždy jen jeden.
Zatím jsem nevyzkoušel příkaz sax2 -r -m 0=radeon třeba pomůže (zkusím v pondělí), ale stejně pokud se nepletu tím nenatáhnu fglrx driver
Pokud by ale někdo viděl v mém postupu, v čem je problém, tak mi dejte, prosím, vědět. Včera jsem si s tím hrál do půlnoci a to ráno v 5:00 vstávám :-(

shinigami odpověděl -

budou otevrene drivery v hlavnim repository, ktere se budou menit spolu s jadrem... kazdopadne nezkuseneho uzivatele asi dost nepotesi, kdyz mu po uspesne instalaci prvni update systemu zlikviduje grafiku...

thomaszko odpověděl -

Presne to se mi take stalo kdyz jsem konecne rozbehal webkameru.
Upgradoval jsem jadro a mel jsem po webkamere a do noveho jadra jsem nesehnal uz ovladac.

Dacesilian odpověděl -

Prosím vás,
po one-click instalaci mi XServer už nastartoval, pořád ale nemám ATI driver, nýbrž Mesa.
Můžete sem prosím napsal link, kde se tento problém řeší? Hledal jsem a nenašel.

Děkuji vám.

Scarysek odpověděl -

Ahoj, neví někdo, kde je chyba, když mi OneClick Install vždy vypíše xmesage: Přístup odmítnut, neoprávněný přístup do paměti...

t_m odpověděl -

zkus to jako root..

Jirka odpověděl -

Nainstaloval jsem nvidia drivery pomoci 1-click install a po restartu mi nenabehl xserver. Pise to:

Skipped services in runlevel 5:
(to nevim, jestli s tim souvisi)

Pokud spustim x (startx), pise to sekvenci podobnych chyb:

sed: cound't open temporary file /etc/sysconfig/sedh...
Warning! MD5DIR is not set : you probabaly called this script outsice SuSEconfig... !
Using MD5DIR="/var/adm/SuSEconfig/md5"....

Jak se da obnovit puvodni konfigurace xserveru, abych mohl X nastartovat bez ovladacu? Sax2 spoustet nezle, protoze ten se vzdy se snazi spustit Xserver, coz se mu nepodari.

Diky, Jirka

Creator odpověděl -

Samozrejme ze zazalohovaneho /etc/X11/xorg.conf. Instalatory grafickych ovladacu obvykle ze slusnosti zachovaji puvodni soubor a jen ho prejmenuji. Jistejsi je udelat si vlastni kopii pred zapocetim experimentu.

V pripade nouze obvykle pomuze v danem souboru v sekci "Device" prepsat polozku Driver zpatky na "nv", "radeon" (v zavislosti na vyrobci karty) nebo univerzalni "vesa". Tim zmenite pouzivany ovladac a X server by mel opet fungovat.

Rikejte to kazdemu, kdo si chce nainstalovat ovladace ke graficke karte, protoze ja to tady rikam neustale a nestaci to.

dcheaven odpověděl -

Jsem lama, ale co takhle spustit yast, a v yastu je odinstalovat?
Když mi před časem nefungovaly ovladače k mojí ATI Radeon, řešil jsem stejný problém, a vyřešil jsem to právě takhle.
________________________________________________________
Hurá, Vista je tady! Uvažte si oprátku, dokud je z čeho.

ra100 odpověděl -

to Jirka (bez ověření) Čt, 2007-10-18 00:43

"Nainstaloval jsem nvidia drivery pomoci 1-click install a po restartu mi nenabehl xserver."
Treba sa prepnut do konzoly (ctrl+atl+f1), potom zadat init 3 a nakoniec sax2 -r (samozrejme ako root)

"Jak se da obnovit puvodni konfigurace xserveru, abych mohl X nastartovat bez ovladacu?"

http://www.suseportal.cz/wiki/index.php/Deaktivace_ovladače_společnosti_nVidia

ptomes odpověděl -

Ovladače pro uživatele Radeon Xpress 200 až 1250 a všech Mobility Radeonů, které potřebují ovladač 8.40.4, jsou již dostupné na jedno kliknutí.

ra100 odpověděl -

A este jeden navod na ATI 8.42.3

lame odpověděl -

no Legacy pro stare katry... ale Rivu TNT2 ovladace nepodporuji :(

robilrobil odpověděl -

Jenomže jednoklik nefunguje pro integrovanou grafiku ATI X1200

Kubix5 odpověděl -

To nefunguje na více ATI grafických karet :-D . Sám mám ATI X1650 ,nainstaluju to a nic :-). Jednoduše se to chová, jako kdyby ten one-click vubec nebyl nainstalovany.

Neznámý odpověděl -

tak tak a nejhorsi je, ze v 10.3 to celkem fungovalo

lukeX odpověděl -

nainstaloval jsem opensuse 10.3, hnedka potom 1 click ovladač nVidie (mám GF 6600) a zapnul jsem "efekty pracovního prostředí"... odhlásil a přihlásil jsem se a nějak se mi nezobrazovay záhlaví oken... tak jsem efekty pracovního prostředí vypnul... když potom, když jdem se přihlásil a otevřel okno efekty pracovního prostředí, tak to vypisuje chybu:

Chybný typ: Očekával jsem 'int', ale obdržel jsem 'string' pro klíč /apps/compiz/plugins/wobbly/screen0/options/map_effect

co s tím??

Kamil Sasýn odpověděl -

Chci se zeptat, zda se vám podařilo rozchodit Compiz Fusion?

Vašek odpověděl -

Mám stejný problém. Vyřešil to někdo?

JirkaZ odpověděl -

instalaci na systému s poněkud starší kartou (nVidia GeForce2 MX400) a bohužel - úspěch se nedostavil. Lépe řečeno obráceně - díky známému "triku" v xorg.conf (nvidia versus nv) pak nenaběhl ani X server...

Řešením byl klasický postup: doinstalace gcc kompilátoru a zdrojového tvaru jádra, pak stažení a spuštění instalátoru ovladače z webu nVidia (*.run) a přes drobné nedodělky (nesprávné hlášky instalátoru) bylo za chvilku hotovo.

Přece jen instalace typu "klikni na jeden universální *.exe" jako ve Windows jsou ještě poněkud nefunkční. Myslím ale, že to je spíš dobře - důvodem je mj. i horší možnost šíření škodlivého software.

Ludek odpověděl -

Vypadá slibně, ale nefunguje to. Rozhodně to není "One click install", alespoň ne na
Lenovo R61i s OpenSuSE 10.3 64bit a nVidií quadro kartou :-/.

bit odpověděl -

Ja sem musel po instalaci spustit jeste "sax2 -r" (jako root), aby zacala fungovat podpora 3d (ATI X1600XT).

Kubix5 odpověděl -

Baviš se o openSuse 10.3? a funguje ti 3D akcelerace v pohode bez problemu??

Kubix5 odpověděl -

Prosim vás, je tu nekdo, komu se podařilo nebo ví jak zprovoznit na ATI X1650 3D Akcelerátor pod openSuSE 10.3? Prosim napište mi sem stručně jak se vám to podařilo a popřípadně jakej ovladač jste k tomu zázraku :-) potřebovali. Děkuji za odpověd.

Maggots odpověděl -

Prosim poradil by mi nekdo s compiz fusion ovladace vse mam ale mam naky sekly obraz ale hybat s kostkou muzu i s mysi nevim cim to je Ati radeon x1650 prosim icq :
75 29 906

Neznámý odpověděl -

Čau poradi mi nekdo jak muzu updatovat driver ke graf. karte.
otreboval bych presnej postup dik.....429787678

Neznámý odpověděl -

po instalaci ovladačů ati po mně chce heslo ale nemůžu tam nic napsat diky za pomoc

xhc odpověděl -

po instalaci ovladačů ati po mně chce heslo
zväčša je to opačne: heslo pýta pred inštaláciou, skutočne neviem, čoho sa tvoj prípad týka

ale nemůžu tam nic napsat
hmmm, máš ruky zviazané o stoličku?? niekto ti drží pištoľ pri hlave?? máš to niekym zakázané??

nič v zlom, ale daj si šancu a napíš svoj problém ako človek..

--------------
KDE SC 4.x
http://ilusoria-yhwh.webovka.eu
----------------------------------------

Aidamos odpověděl -

+1 (taky jsem nepochopil, co tím autor myslí, četl jsem to 3x a nic)