2 příspěvky / 0 new
Poslední
Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
virtualbox

zdrawim, nevedel by mi niekto poradit s tymto problemom ?? nainstaloval som si balik virtualbox verziu 1.4.0 a ked som do konzoli napisal VirtualBox, tak mi vypisalo tuto hlasku:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (2.6.16.13-4-default) or it failed to
load. Please recompile the kernel module and install it by

sudo /etc/init.d/vboxdrv setup

You will not be able to start VMs until this problem is fixed.
WARNING: The compilation of the vboxdrv.ko kernel module failed during the
installation for some reason. Starting a VM will not be possible.
Please consult the User Manual for build instructions.
/opt/VirtualBox-1.4.0/VBoxSVC: error while loading shared libraries: libdbus-1.so.3: cannot open shared object file: No such file or directory

... a nasledne potom mi vyhodilo tabulku s chybou:

Failed to create the VirtualBox COM object
Callee RC: 0x80470007

... nevie niekto, co s tym ??

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
Postupoval jste podle tohoto

Postupoval jste podle tohoto návodu?
http://virtualbox.org/download/UserManual.pdf
Máte nainstalované: gcc, make a kernel-source?

honzaS

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
... tak, uz sa mi podarilo

... tak, uz sa mi podarilo zaviest aj to jadro, ale teraz, ked to pustim, tak mi vypise, ze chyba libdbus-1.so.3, tak som aj skusal nainstalovat nejaky balik, ktory obsahuje tuto kniznicu, ale vypisuje to stale

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
A je mezi balíčky které

A je mezi balíčky které jste instaloval také balíček dbus-1 ?

honzaS

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
ano, mam aj tento balik

ano, mam aj tento balik nainstalovany vo verzii 0.60-30

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
Jaký je kompletní název

Jaký je kompletní název toho balíčku? Protože jsem knihovnu libdbus-1.so.3 našel pouze v balíčku dbus-1-1.0.0-7
http://download.opensuse.org/distribution/10.2/repo/oss/suse/

honzaS

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
no, praveze tuto kniznicu,

no, praveze tuto kniznicu, co ste mi napisali som skusal a vypisalo mi pri instalacii tieto chyby:

error: Failed dependencies:
libdbus-1.so.2 is needed by (installed) dbus-1-glib-0.60-30.i586
libdbus-1.so.2 is needed by (installed) dbus-1-qt3-0.60-30.i586
libdbus-1.so.2 is needed by (installed) hal-resmgr-0.1_SVNr77-12.i586
libdbus-1.so.2 is needed by (installed) hwinfo-12.29-3.i586
libdbus-1.so.2 is needed by (installed) libgnome-2.12.0.1-26.i586
libdbus-1.so.2 is needed by (installed) libbonoboui-2.10.1-23.i586
libdbus-1.so.2 is needed by (installed) libgnomeui-2.12.0-28.i586
libdbus-1.so.2 is needed by (installed) libgnomesu-1.0.0-29.i586
libdbus-1.so.2 is needed by (installed) gnome-desktop-2.12.2-23.i586
libdbus-1.so.2 is needed by (installed) librsvg-2.12.7-16.i586
libdbus-1.so.2 is needed by (installed) gnome-menus-2.12.0-29.i586
libdbus-1.so.2 is needed by (installed) gucharmap-1.4.4-22.i586
libdbus-1.so.2 is needed by (installed) grip-3.2.0-44.i586
libdbus-1.so.2 is needed by (installed) dbus-1-gtk-0.60-30.i586
libdbus-1.so.2 is needed by (installed) dbus-1-python-0.60-30.i586
libdbus-1.so.2 is needed by (installed) xmms-plugins-1.2.10-44.5.i586
libdbus-1.so.2 is needed by (installed) powersave-libs-0.12.20-0.3.i586
libdbus-1.so.2 is needed by (installed) dia-0.94-41.5.i586
libdbus-1.so.2 is needed by (installed) evolution-data-server-1.6.0-43.58.i586
libdbus-1.so.2 is needed by (installed) NetworkManager-kde-0.1r588481-1.4.i586
libdbus-1.so.2 is needed by (installed) hal-0.5.6-33.14.3.i586
libdbus-1.so.2 is needed by (installed) libgphoto2-2.2.0-1.guru.suse101.i686
libdbus-1.so.2 is needed by (installed) dhcdbd-1.12-19.3.i586
libdbus-1.so.2 is needed by (installed) MozillaFirefox-2.0.0.4-1.2.i586
libdbus-1.so.2 is needed by (installed) libzypp-1.3.2-0.9.i586
libdbus-1.so.2 is needed by (installed) control-center2-2.12.2-62.15.i586
libdbus-1.so.2 is needed by (installed) gnome-vfs2-2.12.2-58.11.i586
libdbus-1.so.2 is needed by (installed) sax2-7.1-125.19.i586
libdbus-1.so.2 is needed by (installed) gimp-2.2.14-1.guru.suse101.i686
libdbus-1.so.2 is needed by (installed) nautilus-2.12.2-64.17.i586
libdbus-1.so.2 is needed by (installed) powersave-0.12.20-0.3.i586
libdbus-1.so.2 is needed by (installed) kdebase3-SuSE-10.1-58.11.i586
libdbus-1.so.2 is needed by (installed) kdebase3-3.5.1-69.35.3.i586
libdbus-1.so.2 is needed by (installed) compiz-cvs_060616-1.16.i586
libdbus-1.so.2 is needed by (installed) libzypp-zmd-backend-7.1.1.0-42.53.i586
libdbus-1.so.2 is needed by (installed) NetworkManager-0.6.2-32.11.i586
libdbus-1.so.2 is needed by (installed) kpowersave-0.6.2-3.3.i586
libdbus-1.so.2 is needed by (installed) k3b-0.12.14-12.i586
libdbus-1.so.2 is needed by (installed) helix-dbus-server-0.2.2-6.i586
libdbus-1.so.2 is needed by (installed) kdbus-0.8.6_SVN_20060215-14.i586
libdbus-1.so.2 is needed by (installed) hwinfo-devel-12.29-3.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-glib-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-mono-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-qt3-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-x11-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-devel-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-qt3-devel-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-gtk-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-java-0.60-30.i586
dbus-1 = 0.60-30 is needed by (installed) dbus-1-python-0.60-30.i586
RESULT=1

a ked som to skusal instalovat bez kontroly zavislosti, tak to vypisalo toto:

warning: waiting for transaction lock on /var/lib/rpm/__db.000

... instaloval som to cez KPackage

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
Zkuste ten balíček

Zkuste ten balíček nainstalovat přes Smart nebo Yast, protože podle výpisu bude pro jeho instalaci zapotřebí aktualizovat všechny balíčky zmíněné v závislostech.
(Zdroj pro Smart - 10.2: typ: yast2 ; kanál: http://download.opensuse.org/distribution/10.2/repo/oss)

honzaS

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
a mozem normalne bez obav

a mozem normalne bez obav upgradovat tieto baliky, aj ked su pre verziu 10.2 ?? Ja mam 10.1

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
Určitě bych to

Určitě bych to nedoporučoval a s největší pravděpodobností by to ani nešlo v rámci různých závislostí. Vyhledejte si na tomtéž serveru adresář pro vaši verzi SUSE.
Ale nevím, jestli to váš problém ve výsledku vyřeší, protože verze dbus-1-0.60-30.i586.rpm obsahuje libdbus-1.so.2
Nenainstaloval jste si náhodou verzi virtualboxu určenou pro SUSE 10.2?

honzaS

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 09.07.2007 - 15:28
z www.virtualbox.org som si

z www.virtualbox.org som si stiahol verziu 1.4.0, ale ta bola pre suse 10.2, potom som skusal verziu 1.3.8, ale to si nie som isty, ci to bola pre verziu 10.1, alebo 2. Kde by som nasiel virtualbox pre verziu 10.1 ??

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele honzaS
Offline
Naposledy viděn: 14 let 4 měsíce zpět
Připojen: 09.01.2007 - 15:20
Na těchto stránkách rpm

Na těchto stránkách rpm balíček pro 10.1 není, jestli je někde na netu ke stažení, bohužel nevím.
Na stránkách virtualboxu je v sekci Downloads položka "All distributions", na té samé stránce je také manuál v pdf. V něm je proces instalace přes .run soubor popsán.
Před spuštěním instalačního scriptu musíte mít nainstalované vše potřebné, viz pdf.

honzaS