1 příspěvek / 0 new
Poslední
Neznámý
Obrázek uživatele Neznámý
Nefunkční aplikace závislé na GTK v KDE

Dobrý den,
mám několik měsíců Suse Linux 10.1. s grafickým prostředím KDE (předtím jen Windows). Zkoušel jsem dle postupu na opensuse rozchodit XGL + Compiz. Musel jsem kvůli tomu přinstalovat a aktualizovat některé závislé balíčky pro Gnome. Nakonec jsem zjistil, že má grafická karta Radeon 900 Pro na to opravdu nedostačuje. Vrátil jsem tedy zpět zálohy upravených konfiguračních souborů a pro restartu zas vše naběhlo jak má. Jenže brzy jsem zjistil, že většina aplikací využívajících GTK z Gnome se vůbec nespustí(zkoušel jsem GIMP, DIA, ...), alespoň FireFox se mi ještě spouštěl, ale když jsem chtěl dát uložit nějakou stránku, vždy spadl :-(. Napadlo mě, že jsem si tím pokusem nějak naboural Gnome. Zkusil jsem tedy zaktualizovat všechny balíčky, které my YAST našel s výrazy Gnome a GTK. Část se stáhla, ale na některých mi při instalaci řval chyby typu, že nemůže přepsat nějaký soubor nebo chyby přímo ve zdrojích (neplatná nějaká konstanta metoda a tak ...). Výsledek je nakonec ten, že už se mi nespustí ani FireFox, ani např. OpenOffice. KDE aplikace běží bez problému. Obávám se, že to Gnome už do kupy nedám a budu muset přeinstalovat (asi už bych teď zkusil 10.2), ale moc se mi do toho nechce. Proto se chci tady zeptat, zda by mi někdo v Linuxu zkušenější nepomohl tento problém vyřešit nebo mě alespoň nenasměroval správným směrem, abych tento problém pokud možno bez reinstalace systému vyřešil.
Děkuji předem moc za jakoukoliv radu (buď tady v diskuzi nebo na e-mail ats@centrum.cz).

Obrázek uživatele koty
Offline
Naposledy viděn: 14 let 5 měsíců zpět
Připojen: 19.04.2005 - 11:12
Když se pokusíte některou

Když se pokusíte některou aplikaci spustit z konzole, tak se něco vypíše?