1 příspěvek / 0 new
Poslední
Obrázek uživatele korda_2004
Offline
Naposledy viděn: 13 let 1 měsíc zpět
Připojen: 26.08.2006 - 10:43
Genealogie

Zdravím, sháním nějaký soft na genealogii pro suse 10.0 64 bit, sice sem nalezl Gramps, ale ten bohužel není pro můj systém a na netu jsem nic rozumného nenalezl. Nemáte někdo nějaký tip?
Díky

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
O ničem jiném

než je Gramps nevím, i když hledejte. Gramps si jednak můžete zkompilovat sám (na netu jsou podrobné návody), jednak se říká, že 32bitové balíčky většinou jdou nainstalovat a běhají i na 64bitových systémech.

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Balíček

> webpin gramps

* gramps: Genealogical Research and Analysis Management Programming System
- 2.2.10 [BS::home:/rbos]

Takže one click

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
No nevím....

tazatel má 10.0 64bit, takže pro 10.0 (i když 32bit) je balíček gramps tady.

Pro 10.0 alespoň mně Webpin jaxi nefunguje a taky mám pocit, že pro tuto verzi 1-click (*.ymp) taky ještě nefungoval ;-)

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
A jéje

Nachytal ste mě při nepozornosti :-)

Já tam viděl 10.3. Tak ano, tento balíček je jen pro 10.3 :-/

Jinak váš odkaz vede na SLE 10. Nejsem si jist, jestli je to kompatibilní s 10.0

Pro tazatele: 10.0 už nepodporuje ani BuildService (SLE 10 samozřejmě ano), tudíž shánění balíčku bude veelmi obtížné. Měl by jste zvážit upgrade.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
Ano, upgrade

bych velmi podporoval. A při té příležitosti bych i řešil, zda je opravdu nezbytně nutná 64bitová verze. Je údajně o něco rychlejší funkce dostatečným důvodem k potížím? 64bit je prostě méně rozšířená a z toho plynou nedostatky balíčků atd....

K tomu 10.0/SLE: nebyl bych si tak jistý, mrkněte sem ;-) Je fakt, že SUSE v průběhu historie prodělalo několikero přejmenování a já sám si to už nějak nepamatuju (měl jsem v tom zmatek už tehdy), ale tohle by snad mělo "sedět"...

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Opentura

Dovolil bych si oponovat. Když máme 64bitový hardware, proč nepoužívat 64bitový OS. A Naštěstí OpenSUSE nemá s během 32bitových aplikací problémy, takže já jsem rozhodně proti 32bitovému OS na 64bitech.

S balíčky situace také není špatná. Většina Buildících mašin, jmenovitě Packman a BuildService, buildí duálně pro obě architektury. Schválně se podívám, proč ten SLE balík není i 64bitový, ale jak jste již napsal, neměl by být problém používat 32bitový balík.

EDIT: Ech, všechno jinak :-) . 64bitový balík není proto, že není ani 32bitový. Jelikož se jedná o Pythoní program, je noarch.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
Teď jsem to nějak

nepochopil... 32bitový balík Gramps není podle Vás pro jakou verzi SUSE?

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Noarch

Balíček je noarch, tudíž je na architektuře nezávislý.

Takže tazatel by se instalace neměl bát, mělo by to běžet všude, kde je k dispozici python, tudíž skoro všude.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
Jo aha,

budete mít pravdu... Porovnal jsem balíčky z repozitářů pro SL10.0 (což by snad už podle označení měla být opravdu verze 10.0, nikoliv SLED) a openSUSE10.3 a zdají se být totožné...

JirkaZ

Obrázek uživatele korda_2004
Offline
Naposledy viděn: 13 let 1 měsíc zpět
Připojen: 26.08.2006 - 10:43
Dobře,

děkuji všem za rady, momentálně jsem ve fázi, kdy si vše instaluji za pomocí yastu, ovšem s tímto SW má potíže, ikdyž ho Yast již nabízí, tak tvrdí, že má nevyřešené závislosti kvůli libtotem-plparser.so.0, avšak když se podívím do již nainstalovaných balíků, tak mám nainstalován Totem, jehož součástí tento balík je. Prostuduji tedy nějaké materiály na netu a uvidím pohnuli s tím. Ještě jednou díky.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
Pořád totéž...

Používejte Smart s korektně nastavenými zdroji (repozitáři, kanály, jak chcete). Podobné problémy prakticky už vůbec neznám.

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Mno jo

Dovolte, abych si rýpnul, ale vy prakticky vůbec nepoužíváte OpenSUSE 10.0 ;-)

Jinak o správci balíčků to není. Webpin mi zadanou knihovnu vůbec nenachází :-( . Tak jsem v koncích.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
1:1,

teď jste zase dostal Vy mě, myšlenková setrvačnost je potvora ;-) Na druhou stranu - jakže to Webpinem hledáte pro 10.0?

K věci pro kolegu tazatele: jak už bylo řečeno, upgradujte. A to nejlépe rovnou na 10.3, tato poslední verze je už venku dostatečně dlouho a dá se říct, že je dobře odladěná.

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
1:2 :-D

A bod opět pro vás :-D

Ta jsem se zastyděl a šel zopakovat hledání. Tentokráte ne na přesný název soubru, ale alespoň na podobný.

A
našel.

totem (2.20.0)
Movie Player for the GNOME Desktop
contains /usr/lib/libtotem-plparser.so.7

Zkusil bych tedy "miniprasárnu"

Spustit konzoli (konsole), přihlásit se jako admin příkazem "su -", přesunout se do onoho adresáře "cd /usr/lib", a udělal symbolický link "ln -s libtotem-plparser.so.7 libtotem-plparser.so.0".

Pomůže to? A vůbec, je tam onen soubor? Až budete v usr/lib, napiště "la libtotem*", mělo by to vyjet všechny soubory, co začínají na libtotem. Pokud je nějaký plparser.so.něco, udělejte symbolický link (příkaz výše, akorát nahraďte tu sedmičku tím, co je u vás).

Ale toto je jen pokus.

EDIT:
Jo a Jirka má samozřejmě pravdu s tím upgradem. Ale pokud se vám opravdu nechce, doporučuji počkat na 11.0 (+- 2 měsíce)

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 2 týdny zpět
Připojen: 17.10.2006 - 19:12
Ad upgrade...

Já bych se verzi 11.0 rozhodně vyhnul, přinejmenším zpočátku. Bude to opět syrové a neodladěné, navíc má používat KDE4 - to bude další velký zdroj problémů (pokud - v tomto případě - tazatel nepoužívá Gnome).

Myslím, že dnes a ještě dost dlouho dopředu bude optimální už dozrálá 10.3.

Samozřejmě pokud někdo nechce spolehlivost a hodlá experimentovat, pak je vše jinak...

JirkaZ

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
ad upgade..

Celé OpenSUSE je experiment ;-) . Stable je SLE řada.

Já bych se 11.0 nebál. A KDE je volitelné, je možné si při instalaci říci o 3.9.1

Obrázek uživatele korda_2004
Offline
Naposledy viděn: 13 let 1 měsíc zpět
Připojen: 26.08.2006 - 10:43
11.0

V podstatě to je tak, že skutečně čekám na 11.0 s 10.0 64bit jsem navýsost spokojený, a na 10.3 64bit jsem se ukrutně navztekal např. s rozchozením firefox+JRE a rozumně jsem to nerozchodil do dneška (všechny návody a rady zklamali). Snad s 11.0 budu mít štěstí, ale to je na jinou debatu.

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Ok :-)

Jj. A zkusil jste ten trik se symbolickým linkem?

Obrázek uživatele korda_2004
Offline
Naposledy viděn: 13 let 1 měsíc zpět
Připojen: 26.08.2006 - 10:43
Bohužel,

nepomohlo, ten soubor existuje, je v /opt/gnome/lib64 (libtotem-plparser.so.0) linky sem nadělal jak do aktuálního adresáře tak i do /usr/lib leč přeto odmítne instalovat potřebný balík Phyton-gnome-extras, který je potřeba právě pro Gramps.

Obrázek uživatele Ilfirin
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 06.12.2006 - 17:39
Ignorovat závislosti

Jaj, já jsem myslel že to nejde spustit... Balíčkovací systém na soubory na disku kašle, zajímá ho, jestli balíček poskytující danou závislost je nainstalován.
To se nám určitě nepovede, tak dejte instalovat balíček i přes nesplněné závislost (je tam ta volba). Program už bude hledat soubor na disku (ten zas kašle na balíčkovací systém) a na to už máme vytvořené symbolické linky.

Takže by to mělo jet.

Obrázek uživatele korda_2004
Offline
Naposledy viděn: 13 let 1 měsíc zpět
Připojen: 26.08.2006 - 10:43
Zdá se to být O.K.

Je to velký, soft naběhl, zatím jsem ho příliš netestoval, ale to se brzo změní, takže děkuji velice za spolupráci, měl sem jen strach ignorovat a způsobit nestabilitu :-).